samba網芳設定問題

顯示結果從第 1 筆 到 10 筆,共計 10 筆
  1. #1
    海誓山盟都是屁
    註冊日期
    2000-10-21
    所在地區
    雙向100M
    討論區文章
    346

    samba網芳設定問題

    家中區網目前使用IP分享器,
    連接五台xp pro電腦,
    使用fedora 8 架設samba,
    其他電腦都已經可以在網路芳鄰裡面找到samba伺服器,
    samba伺服器裡有建立一個資料夾作分享,
    但是其他使用者想要進入資料夾不管samba伺服介面怎樣設定,
    不管是設定共享,資料夾勾選允許所有使用者,
    或是允許特定使用者,也有在samba使用者建立使用者了,
    但是其他xp pro使用者去點選資料夾都會出現
    無法存取,沒有資源使用權的錯誤訊息...
    已經搞了兩天了,也照書本上設定,但就是無法成功連進資料夾
    作新增修改刪除,而且在samba新增使用者裡,
    unix的名稱同樣的只能一個嗎?
    我不想用到unix只想用到windows設定,
    請問有前輩可以指點一下嗎?謝謝


    十里平湖霜滿天
    寸寸青絲愁華年
    對月形單望相護
    只羨鴛鴦不羨仙
    十里坡~

  2. #2
    會員
    註冊日期
    2006-07-11
    所在地區
    小水管
    討論區文章
    44

    回覆: samba網芳設定問題

    === 以您目前所遇到的問題,提供您一個超讚的學習地方 ===
    鳥哥的 Linux 私房菜
    http://linux.vbird.org/

    一個字 "讚" !!
    ( ̄#)3 ̄) 培養足夠的默契以前,你聽不懂我的語言 ( ̄ε(# ̄)

  3. #3
    Kree linux_xp 的大頭照
    註冊日期
    2002-01-19
    討論區文章
    2,655

    回覆: samba網芳設定問題

    首先,去下 webmin
    http://www.webmin.com/download.html

    下 webmin-1.410-1.noarch.rpm 那一個

    丟到 Linux,安裝它:
    # rpm -ivh webmin-1.410-1.noarch.rpm

    -----------------------------------------------------

    在 windows 電腦,打開瀏覽器

    網址:https://(Linux主機的IP):10000

    Linux 主機的 IP,自行替換,埠號 10000,協定 https (SSL加密)

    若沒有畫面,表示防火牆沒開,去把它打開,tcp 10000 allow 進入

    登入帳號:root
    密碼:同 Linux root 密碼


    [伺服器]-[samba] 設同步


    接著,建立 Linux 帳號 = 同步建立 samba 帳號





    使用者名稱:用來登入 Linux 和 samba 用的
    密碼:選 「純文字密碼」,輸入密碼

    其餘不用管,按確定新增,帳號就新增好了

    ---------------------------------------------------
    編輯 /etc/samba/smb.conf

    範例參考:
    語法:
    #==== 全域設定 ====
    [global]
            dns proxy = no
            log file = /var/log/samba/%m.log
            netbios name = share
            cups options = raw
            load printers = no
            server string = Samba Server
            local master = yes
            workgroup = WORKGROUP
            os level = 33
            interfaces = eth0
            domain master = yes
            hosts allow = 192.168.0. 127.
            security = user
            max log size = 50
            wins support = true
    
    #====== 分享的目錄 =======
    
    [1 - Video]
            comment = video
            path = /smb/video
            read only = no
            public = no
            create mode = 0644
            directory mode = 0755
    
    
    [2 - Music]
            comment = music
            path = /smb/music
            read only = no
            public = no
            create mode = 0644
            directory mode = 0755
    
    [3 - Soft]
            comment = soft
            path = /smb/soft
            read only = no
            public = no
            create mode = 0644
            directory mode = 0755
    
    [4 - Share]
            comment = share
            path = /smb/share
            read only = no
            public = no
            create mode = 0666
            directory mode = 0777
    看是要把原先內容清空,複製-貼上 這個範例
    或是一個個慢慢修改,隨便

    注意要在 Linux 編輯,或用支援 Linux 的文書編輯器
    語系:UTF-8
    文字斷行格式:unix

    全域設定中,要注意這幾個項目:
    --------------------------------------------
    interfaces = eth0 <----------對內網卡編號

    hosts allow = 192.168.0. 127. <-------允許進入的網段

    這裡要用 smb 的特殊縮寫
    例如:192.168.0.0/24,就寫 192.168.0. 即可

    security = user <---- 安全性狀態

    安全性狀態,user 表示要用帳號登入,才能使用

    ※ 只需改這三個項目,其餘不用管,照抄


    分享目錄 - 如何設定?
    (上面那個範例,沒有修改是不能執行的,啟動不會 ok)
    --------------------------------------------------------

    [在windows看到的目錄名稱]
    comment = share <---鼠標移過去出現的註解
    path = /smb/share <---- 目錄位置
    read only = no <---- 唯讀 (no)
    public = no <---- 任何人都可進去?(no)
    create mode = 0666 <---- 新建檔案,權限值?
    directory mode = 0777 <--- 新建目錄,權限值?

    ※1 格式就是這樣子,看要分享幾個目錄,就弄幾個,格式都一樣,複製-貼上 就好

    ※2 上面範例列了四個分享目錄,那是範例,用不到的刪除,或前面加 # 註解起來

    ※3 Linux 硬碟中,要真的有那些目錄,否則 smb 開不起來,去建立就好了


    /etc/samba/smb.conf 編輯好後

    重新啟動 samba,使其生效:
    # /etc/rc.d/init.d/smb restart

    綠色 [ok] :啟動成功
    紅色 [失敗]:啟動失敗,設定檔有問題,再去修一修


    smb.conf (samba 設定檔)
    要在 webmin 圖形介面,直接改也是可以啦
    不過我是覺得直接改文字檔比較快,webmin 那個寫啥小,看不懂啦
    有興趣可自行研究看看

    =============================

    windows 端如何連到 samba?

    不要用網路網鄰,因為很慢,手電筒在那照半天..... zzzZZZzzz

    打開任何具網址列的視窗,例如檔案總管
    網址輸入:\\ Linux 主機的 IP
    範例:\\192.168.0.254

    注意前面是「反斜線」
    這樣就能連進去了,瞬間開啟!

    可以在桌面新增「捷徑」,位址:\\ Linux主機IP
    點兩下捷徑,開啟 samba


    samba 使用的 port:137、138、139
    若 Linux 有開防火牆,記得開啟這些 port

    - END -

  4. #4
    會員
    註冊日期
    2001-05-18
    討論區文章
    1,938

    回覆: samba網芳設定問題

    引用 作者:xwincd 瀏覽文章
    家中區網目前使用IP分享器,
    連接五台xp pro電腦,
    使用fedora 8 架設samba,
    其他電腦都已經可以在網路芳鄰裡面找到samba伺服器,
    samba伺服器裡有建立一個資料夾作分享,
    但是其他使用者想要進入資料夾不管samba伺服介面怎樣設定,
    不管是設定共享,資料夾勾選允許所有使用者,
    或是允許特定使用者,也有在samba使用者建立使用者了,
    但是其他xp pro使用者去點選資料夾都會出現
    無法存取,沒有資源使用權的錯誤訊息...
    已經搞了兩天了,也照書本上設定,但就是無法成功連進資料夾
    作新增修改刪除,而且在samba新增使用者裡,
    unix的名稱同樣的只能一個嗎?
    我不想用到unix只想用到windows設定,
    請問有前輩可以指點一下嗎?謝謝
    smbpasswd -a username

  5. #5
    海誓山盟都是屁
    註冊日期
    2000-10-21
    所在地區
    雙向100M
    討論區文章
    346

    回覆: samba網芳設定問題

    照著做了...
    結果還是一樣...
    網芳看的到主機...點進去第一層目錄看的到
    但是要進去個別資料夾就說沒有權限了
    我已經設定成全部不設限了,還是無法完成,
    都是看的到但是進不去,不然就是有要輸入帳號密碼的視窗出來,
    但是帳號那邊是灰色的無法輸入,只能輸入密碼部分,
    但是密碼不管輸入什麼都是無法進入...
    快瘋了>"<
    會是因為xp pro使用者每個都是admin的關係嗎?


    此文章於 2008-03-29 10:11 AM 被 xwincd 編輯。
    十里平湖霜滿天
    寸寸青絲愁華年
    對月形單望相護
    只羨鴛鴦不羨仙
    十里坡~

  6. #6
    會員
    註冊日期
    2001-05-18
    討論區文章
    1,938

    回覆: samba網芳設定問題

    引用 作者:xwincd 瀏覽文章
    照著做了...
    結果還是一樣...
    網芳看的到主機...點進去第一層目錄看的到
    但是要進去個別資料夾就說沒有權限了
    我已經設定成全部不設限了,還是無法完成,
    都是看的到但是進不去,不然就是有要輸入帳號密碼的視窗出來,
    但是帳號那邊是灰色的無法輸入,只能輸入密碼部分,
    但是密碼不管輸入什麼都是無法進入...
    快瘋了>"<
    會是因為xp pro使用者每個都是admin的關係嗎?
    把 /etc/samba/smb.conf 貼出來看看.
    [public]
    comment = Public
    path = /tmp/temp
    public = yes
    writable = yes

    帳號不能改應該是 連錯了, 連到 xp 了, 先確定 IP 沒錯.

    以 root 登入 開 終端機
    ifconfig <------ 看看 IP 是多少
    useradd test
    passwd test
    123456
    123456
    smbpasswd -a test
    123456
    123456
    mkdir -p /tmp/temp
    chmod 1777 /tmp/temp
    /etc/rc.d/init.d/nmb restart
    /etc/rc.d/init.d/smb restart

  7. #7
    Kree linux_xp 的大頭照
    註冊日期
    2002-01-19
    討論區文章
    2,655

    回覆: samba網芳設定問題

    引用 作者:xwincd 瀏覽文章
    照著做了...
    結果還是一樣...
    網芳看的到主機...點進去第一層目錄看的到
    但是要進去個別資料夾就說沒有權限了
    我已經設定成全部不設限了,還是無法完成,
    都是看的到但是進不去,不然就是有要輸入帳號密碼的視窗出來,
    但是帳號那邊是灰色的無法輸入,只能輸入密碼部分,
    但是密碼不管輸入什麼都是無法進入...
    快瘋了>"<
    會是因為xp pro使用者每個都是admin的關係嗎?
    要注意 Linux 目錄本身也有權限喔

    samba 的權限控制,並無法逾越 Linux 的權限控制
    Linux 的目錄權限是最大的,再來才會參考 smb 的設定

    比方說有一個資料夾:bt
    權限:750 rwxr-x---
    擁有者:bt
    擁有群組:bt

    那這個目錄就只有 bt 這個人和 root 可以進入而已

    一般如果是 root 創建的目錄
    mask 預設權限都是 755
    擁有者:root:root

    所有人都能進入才對,但不能寫入
    要寫入需要 777,或 2775

    四碼的權限值,2 是 setGruop 的意思

    意思是任何人創建這個檔案或目錄,其擁有群組都會變成上層的群組,在多人分享的環境下,需有這種設定

    不過由敘述來看,你是連目錄都進不去,問題是出在別的地方
    估計是權限問題,建議檢查一下目錄的權限值

  8. #8
    海誓山盟都是屁
    註冊日期
    2000-10-21
    所在地區
    雙向100M
    討論區文章
    346

    回覆: samba網芳設定問題

    #==== 全域設定 ====
    [global]
    log file = /var/log/samba/%m.log
    load printers = no
    domain master = yes
    interfaces = eth0
    public = yes
    wins support = true
    dns proxy = no
    netbios name = share
    cups options = raw
    server string = Samba Server
    writeable = yes
    workgroup = mshome
    os level = 33
    security = share
    create mode = 777
    preferred master = no
    max log size = 50
    directory mode = 777
    ; local master = yes
    ; encrypt passwords = yes
    ; guest ok = no
    ; guest account = nobody

    #====== 分享的目錄 =======
    [test]
    path = /media/disk/Intel

    上面是設定檔,現在變成網路芳鄰看不到,但是直接用ip連過去可以進到第一層目錄,但是還是進不了目錄裡面,一點目錄就會說沒有權限...
    十里平湖霜滿天
    寸寸青絲愁華年
    對月形單望相護
    只羨鴛鴦不羨仙
    十里坡~

  9. #9
    會員
    註冊日期
    2001-05-18
    討論區文章
    1,938

    回覆: samba網芳設定問題

    引用 作者:xwincd 瀏覽文章
    #==== 全域設定 ====
    [global]
    log file = /var/log/samba/%m.log
    load printers = no
    domain master = yes
    interfaces = eth0
    public = yes
    wins support = true
    dns proxy = no
    netbios name = share
    cups options = raw
    server string = Samba Server
    writeable = yes
    workgroup = mshome
    os level = 33
    security = share
    create mode = 777
    preferred master = no
    max log size = 50
    directory mode = 777
    ; local master = yes
    ; encrypt passwords = yes
    ; guest ok = no
    ; guest account = nobody

    #====== 分享的目錄 =======
    [test]
    path = /media/disk/Intel

    上面是設定檔,現在變成網路芳鄰看不到,但是直接用ip連過去可以進到第一層目錄,但是還是進不了目錄裡面,一點目錄就會說沒有權限...
    試了 我改 path = /tmp/temp 完全沒問題

    你的有問題應該是沒有權限, public=yes 放在 global
    就和 XP 的 本機安全性原則 安全性選項 網路存取:共用和安全性模式用於本機帳戶 選 僅適用於來賓 - 本機使用者以 Guest 驗證 ㄧ樣
    只能用 guest 帳號所以不能改

    ls -l /media/disk/intel
    other 有沒有存取權

    建議用
    mkdir -p /tmp/temp
    chmod 1777 /tmp/temp
    ln -sf /media/disk/intel /tmp/temp/intel

    把 smb.conf
    [test] 部份改為
    path = /tmp/temp

    /etc/rc.d/init.d/nmb restart
    /etc/rc.d/init.d/smb restart

  10. #10
    海誓山盟都是屁
    註冊日期
    2000-10-21
    所在地區
    雙向100M
    討論區文章
    346

    回覆: samba網芳設定問題

    同樣的設定,在ubuntu7.10是正常可以使用的,
    但是在Fedora 8上設定同樣的東西,卻是失敗...
    同樣的套件有不同的結果= =...大概兩個的安全性預設是不樣的吧...


    十里平湖霜滿天
    寸寸青絲愁華年
    對月形單望相護
    只羨鴛鴦不羨仙
    十里坡~

類似的主題

  1. 【軟體求助】XP HOME版的網芳設定問題.....(已爬文)
    作者:DAVID-BP 所在討論版:-- HELP ME 電 腦 軟 硬 體 急 救 版
    回覆: 17
    最後發表: 2007-01-17, 12:57 PM
  2. 無線、有線之網芳設定??
    作者:autnb 所在討論版:-- 無 線 網 路 版
    回覆: 8
    最後發表: 2004-04-28, 06:30 PM
  3. 【求助】兩張網路卡網芳設定的問題~~已爬文
    作者:mmx9797 所在討論版:-- 網 路 技 術 版
    回覆: 4
    最後發表: 2004-01-05, 05:10 AM
  4. 【求助】VMware的網芳設定
    作者:koma 所在討論版:-- 網 路 技 術 版
    回覆: 4
    最後發表: 2003-05-25, 05:44 AM
  5. xp的網芳設定?
    作者:catch 所在討論版:-- Windows 討 論 版
    回覆: 1
    最後發表: 2002-03-26, 12:30 AM

 

SAMBA 網路上芳鄰 搜尋不到

fedora 18 samba 網路芳鄰

fedora18 samba 無法存取

fedora18 網路芳鄰 沒權限

發表文章規則

  • 不可以發表新主題
  • 不可以回覆文章
  • 不可以上傳附加檔案
  • 不可以編輯自己的文章
  •