![]() |
CentOS 5+Postfix 啟動 SASL2 的問題 環境: CentOS 5 rpm安裝postfix Cyrus-SASL2原本CentOS就有 帳號只有root 原先CentOS saslauthd是安裝在/var/run/saslauthd,已經將它停用,當執行/usr/sbin/saslauthd -a shadow檢驗sasl2是否成功一直出現Another instance of saslauthd is currently running,請問站上先進我的問題是哪邊沒有設定好應如何解決,謝謝。 [url]http://phorum.study-area.org/index.php/topic,39441.msg197665.html[/url] 測試saslauthd的錯誤訊息 [xxx@xxx]# ./usr/sbin/testsaslauthd -u userID -p 'your.passwd' 0: NO "authentication failed" 檢驗sasl2是否成功的錯誤訊息 [xxx@xxx~]# /usr/sbin/saslauthd -a shadow saslauthd[2719] :detach_tty : Cannot start saslauthd saslauthd[2719] :detach_tty : Another instance of saslauthd is currently running 至/var/log/messages觀看的錯誤訊息:[code]saslauthd[2719] :detach_tty : Cannot start saslauthd saslauthd[2719] :detach_tty : Another instance of saslauthd is currently running saslauthd[2595]: detach_tty : could not lock pid file /var/run/saslauthd/saslauthd.pid: Resource temporarily unavailable saslauthd[2594]: detach_tty : Cannot start saslauthd saslauthd[2594]: detach_tty : Another instance of saslauthd is currently running saslauthd[2620]: main : no authentication mechanism specified saslauthd[2456]: server_exit : master exited: 2456 saslauthd[2633]: detach_tty : master pid is: 2633 saslauthd[2633]: ipc_init : listening on socket: /var/run/saslauthd/mux saslauthd[2640]: detach_tty : could not lock pid file /var/run/saslauthd/saslauthd.pid: Resource temporarily unavailable saslauthd[2639]: detach_tty : Cannot start saslauthd saslauthd[2639]: detach_tty : Another instance of saslauthd is currently running saslauthd[2466]: do_auth : auth failure: [user=userID] [service=imap] [realm=] [mech=pam] [reason=PAM auth error][/code] 我的main.cf設定部份[code] # SASL smtpd_sasl_auth_enable = yes smtpd_sasl_local_domain = ' ' broken_sasl_auth_clients = yes smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, check_relay_domains, reject_unauth_destination, message_size_limit = 15728640, mailbox_size_limit = 500000000 smtpd_client_restrictions = permit_sasl_authenticated, check_client_access regexp:/etc/postfix/access smtpd_sender_restrictions = reject_unknown_sender_domain smtpd_sasl_security_options = noanonymous smtpd_sasl_local_domain = $myhostname[/code] /usr/lib/sasl2/smtpd.conf設定部份[code] pwcheck_method: saslauthd mech_list: plain login[/code] /etc/sysconfig/saslauthd設定部份[code] MECH=pam[/code] 不過我的CentOS 5裡面沒有/usr/sbin/pwcheck的執行檔 另外很怪的是,當停用saslauthd,執行ps aux檢查也確定沒有saslauthd在執行,但輸入/usr/sbin/saslauthd -a shadow仍發生相同錯誤訊息 |
| 所有時間均為 +8。現在的時間是 01:55 AM。 |
| XML | RSS 2.0 | RSS |
本論壇所有文章僅代表留言者個人意見,並不代表本站之立場,討論區以「即時留言」方式運作,故無法完全監察所有即時留言,若您發現文章可能有異議,請 email :[email protected] 處理。