【求助】HOST AP 的設定問題...

顯示結果從第 1 筆 到 6 筆,共計 6 筆
  1. #1
    會員
    註冊日期
    2004-12-04
    討論區文章
    4

    【求助】HOST AP 的設定問題...

    請問各位大大~~~
    能不能幫我這個忙
    就是在設定 HOAT AP 的時候
    ifcpnfig eth0 x.x.x.x
    ifcpnfig wlan x.x.x.x
    ifcpnfig br0 x.x.x.x netmask x.x.x.x
    route add default gw x.x.x.x


    這些 x.x.x.x 要怎麼設定阿????如果能 希望能舉個例子

    最近在學架設HOATAP 可是網路上都沒有很詳細說明要怎麼設定
    所以希望知道的高手 能幫我這個忙

    謝謝各位高手幫忙 小弟我感激不儘.....

    PS. 不知道看不看的董我問的東西??
    如果不懂 我在PO詳細一點我的問題



  2. #2
    會員
    註冊日期
    2003-08-25
    討論區文章
    1,120
    引用 作者:jackshih
    請問各位大大~~~
    能不能幫我這個忙
    就是在設定 HOAT AP 的時候
    ifcpnfig eth0 x.x.x.x
    ifcpnfig wlan x.x.x.x
    ifcpnfig br0 x.x.x.x netmask x.x.x.x
    route add default gw x.x.x.x


    這些 x.x.x.x 要怎麼設定阿????如果能 希望能舉個例子

    最近在學架設HOATAP 可是網路上都沒有很詳細說明要怎麼設定
    所以希望知道的高手 能幫我這個忙

    謝謝各位高手幫忙 小弟我感激不儘.....

    PS. 不知道看不看的董我問的東西??
    如果不懂 我在PO詳細一點我的問題
    brctl addbr br0--->先建virtual device br0出來
    ifconfig eth0 up---->把eth0 up起來,但不bind ip上去
    ifconfig wlan0 up---->wlan0也跟eth0一樣
    brctl addif br0 eth0---->讓eth0加入br0這個vritual device
    brctl addif br0 wlan0---->wlan0也一樣
    ifconfig br0 a.b.c.d---->ip是bind在br0那個virtual device上的
    route add default gw x.x.x.x就沒影響了....
    不要,不要,我不要這種顏色的帽子....

  3. #3
    會員
    註冊日期
    2004-12-04
    討論區文章
    4
    非常謝謝 高手幫忙~~~
    (雖然我還沒試成功)
    有問題我會再請教你

    真的非常感謝摟~~

  4. #4
    會員
    註冊日期
    2004-12-04
    討論區文章
    4
    哎呀~~~真糟糕 衣值沒辦法成功~~~
    所以又要請教各位高手大大了~~~
    首先我先說一下我的一些設備 /系統等
    我電腦是: NB
    無線網卡: 華碩 WL-100 PCMCIA (prism 2.5) 而firmware 是1.74
    系統: redhat 9 核心: linux-2.4.20-8
    PS.(我插上網卡 網卡燈會亮 )

    想請教幾個問題:
    Q1. 請問 我的 的無線網卡 是華碩 WL-100 應該可以吧??( 之前爬過文 應 該可以吧?? 說不定是我搞錯)
    Q2. 我安裝過程是從
    http://www.thinkpad.cn/forum/viewthr...ht=&sid=SYUp2p 照著作的

    1. 安装驅動

    ln -s /usr/src/linux-2.4.20-8 /usr/src/linux
    cp /usr/src/linux/configs/kernel-2.4.20-i686.config /usr/src/linux/.config
    tar -zxvf hostap-driver-0.1.2.tar.gz
    cd hostap-driver-0.1.2
    make pccard
    make install_pccard

    2.編譯安装hostapd
    tar -zxvf hostapd-0.1.0.tar.gz
    cd hostapd-0.1.0
    make
    cp hostapd /usr/sbin/
    cp hostapd.conf /etc/
    到目前為止都沒出現錯誤訊息....

    3 啟動hostap。
    modprobe hostap_pccard
    hostapd -B /etc/hostapd.conf
    在 modprobe 的時候 就出現 錯誤了......

    不知道怎麼半~~~是不是我少了蛇麼動作阿??因為我是PCMCIA 會不會是少了蛇麼動作??
    真糟糕~~~一值沒辦法架設完成~~~ 所以請教高手當忙
    真的非常感謝~~~~

  5. #5
    會員
    註冊日期
    2003-08-25
    討論區文章
    1,120
    引用 作者:jackshih
    哎呀~~~真糟糕 衣值沒辦法成功~~~
    所以又要請教各位高手大大了~~~
    首先我先說一下我的一些設備 /系統等
    我電腦是: NB
    無線網卡: 華碩 WL-100 PCMCIA (prism 2.5) 而firmware 是1.74
    系統: redhat 9 核心: linux-2.4.20-8
    PS.(我插上網卡 網卡燈會亮 )

    想請教幾個問題:
    Q1. 請問 我的 的無線網卡 是華碩 WL-100 應該可以吧??( 之前爬過文 應 該可以吧?? 說不定是我搞錯)
    可以,不過你得先確定pcmcia部份有沒有問題,另外要用hostap_cs去驅動這片卡,而不是用orinoco_cs(kernel內建)或prism2_cs(linux-wlan-ng的driver)去驅動.....BTW,把插上卡之後的dmesg貼上來會比較有幫助....

    引用 作者:jackshih
    Q2. 我安裝過程是從
    http://www.thinkpad.cn/forum/viewthr...ht=&sid=SYUp2p 照著作的

    1. 安装驅動

    ln -s /usr/src/linux-2.4.20-8 /usr/src/linux
    cp /usr/src/linux/configs/kernel-2.4.20-i686.config /usr/src/linux/.config
    tar -zxvf hostap-driver-0.1.2.tar.gz
    cd hostap-driver-0.1.2
    make pccard
    make install_pccard

    2.編譯安装hostapd
    tar -zxvf hostapd-0.1.0.tar.gz
    cd hostapd-0.1.0
    make
    cp hostapd /usr/sbin/
    cp hostapd.conf /etc/
    到目前為止都沒出現錯誤訊息....

    3 啟動hostap。
    modprobe hostap_pccard
    hostapd -B /etc/hostapd.conf
    在 modprobe 的時候 就出現 錯誤了......

    不知道怎麼半~~~是不是我少了蛇麼動作阿??因為我是PCMCIA 會不會是少了蛇麼動作??
    真糟糕~~~一值沒辦法架設完成~~~ 所以請教高手當忙
    真的非常感謝~~~~
    hostap作者的homepage在hostap ,鵝現在裝的是2.5版的,1.3版長啥樣有點不太確定了,不過driver應該是hostap_cs而不是hostap_pccard,而且只要pcmcia部份沒問題的話(BTW,/etc/hostap_cs.conf應該有以下這段,而/etc/pcmcia/config或/etc/pcmcia/wlan-ng.conf中不應該有類似的部份,如果有要先remark掉免得掛錯driver),卡一插進去driver應該會自動掛上去而不用手動去掛....

    card "ASUS WL-100 802.11b WLAN PC Card"
    version "ASUS", "802_11b_PC_CARD_25"
    bind "hostap_cs"

    至於hostapd是要跑802.1x或WPA才須要的,只當簡單的AP時是不須要的,只要用iwconfig把wlan0的mode設成master,另外channel和essid就隨你高興了.....



  6. #6
    會員
    註冊日期
    2004-12-04
    討論區文章
    4
    首先 非常感謝wangcm高手的幫忙
    真的非常感謝 ......
    讓我更了解安裝程序
    不過縣在有一個問題........

    我在
    tar -zxvf hostap-driver-0.2.5.tar.gz
    cd hostap-driver-0.2.5
    make
    make install_pccard
    都沒發生問題
    但是
    接著我馬上重新開機 我發現原本網卡燈會亮
    重新開機後 就不會亮了
    而當我執行 modprobe hostap_cs 就發生錯勿
    如下:

    [root@localhost pcmcia]# modprobe hostap_cs
    /lib/modules/2.4.20-8/kernel/drivers/pcmcia/ds.o: init_module: Operation not permitted
    Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
    You may find more information in syslog or the output from dmesg
    /lib/modules/2.4.20-8/kernel/drivers/pcmcia/ds.o: insmod /lib/modules/2.4.20-8/kernel/drivers/pcmcia/ds.o failed
    /lib/modules/2.4.20-8/kernel/drivers/pcmcia/ds.o: insmod hostap_cs failed

    請問 這是什麼錯誤阿 ?(是不是說 IRQ 衝突阿??)
    看了wangcm 高手的回文:
    "不是用orinoco_cs(kernel內建)或prism2_cs(linux-wlan-ng的driver)去驅動.....BTW,把插上卡之後的dmesg貼上來會比較有幫助...."
    我在想是不是因為orinoco_cs或prism2_cs 已經驅動我的網卡
    所以用hostap_cs.conf 驅動ㄉ時候產生衝突??(我猜的啦~~~)

    我輸入: lsmod 會有
    "yenta_socket 13472 1
    pcmcia_core 57216 0 [ds yenta_socket] "
    不知到是不是正常???

    PS. 我有附件檔 111.DOC 是dmesg的結果~~~~.有空可以幫我看看嘛??


    那要怎麼解決阿??
    還是沒救了??(嗚嗚嗚 我不要)

    喔~~對了~~ wangcm高手您說
    "而且只要pcmcia部份沒問題的話(BTW,/etc/hostap_cs.conf應該有以下這段,而/etc/pcmcia/config或/etc/pcmcia/wlan-ng.conf中不應該有類似的部份,如果有要先remark掉免得掛錯driver),卡一插進去driver應該會自動掛上去而不用手動去掛
    card "ASUS WL-100 802.11b WLAN PC Card"
    version "ASUS", "802_11b_PC_CARD_25"
    bind "hostap_cs" ....


    可是阿~~~我卡差進去 /etc/hostap_cs.conf 裡 並沒有產生耶
    怎麼會這樣??不會是網卡壞的吧??(在win 可以跑)

    真的由衷感謝能幫助小弟我的人
    非常感謝
    附加檔案 附加檔案

類似的主題

  1. [求助] 中華電信的AP ASKEY RTW030的設定問題
    作者:000111 所在討論版:-- 無 線 網 路 版
    回覆: 1
    最後發表: 2006-03-25, 10:34 PM
  2. 【求助】AP的設定問題,先說謝謝!
    作者:afu 所在討論版:-- 無 線 網 路 版
    回覆: 6
    最後發表: 2004-12-30, 08:16 PM
  3. 【求助】IIS的設定問題
    作者:Age 所在討論版:-- HELP ME 電 腦 軟 硬 體 急 救 版
    回覆: 0
    最後發表: 2004-10-28, 09:54 PM
  4. 【求助】netscape7 的設定問題!?
    作者:area 所在討論版:-- FreeBSD & Linux 討 論 版
    回覆: 2
    最後發表: 2002-11-11, 09:59 PM
  5. 【求助】MDaemon5.0的設定問題
    作者:hiroshiwang 所在討論版:☉ -- 架 站 DIY 討 論 版
    回覆: 1
    最後發表: 2002-08-04, 01:28 AM

 

rtw 030 wpa 支援

發表文章規則

  • 不可以發表新主題
  • 不可以回覆文章
  • 不可以上傳附加檔案
  • 不可以編輯自己的文章
  •