Cisco IOS routing - 內網無法連上網路 - PCZONE 討論區

返回   PCZONE 討論區 > ▲ ADSL_CABLE_FTTH 寬 頻 上 網 討 論 > -- 網 路 硬 體 版


PCZONE 討論區



通知

-- 網 路 硬 體 版 "網路卡" , "HUB" ,"Switch","無線網路產品","頻寬分享器" 等網路硬體產品

會員
Cisco IOS routing - 內網無法連上網路
目前在使用的是專線, cisco 1841.
從外面可以連至router,並可在router裡ping 內網ip,gateway等等
從內網pc可以ping wan的ip(203.121.26.130), 但沒辦法ping到gateway-203.121.26.129.

請各位大大幫忙看看以下設定是否正確
謝謝

----------------------------------------------

Building configuration...

Current configuration : 1650 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname mywebfon
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 11111111111111111111111
enable password 7 11111111111111111111111
!
no aaa new-model
no ip source-route
!
!
ip dhcp excluded-address 192.168.10.0 192.168.10.34
ip dhcp excluded-address 192.168.10.131 192.168.10.255
!
ip dhcp pool mypool
network 192.168.10.0 255.255.255.0
dns-server 203.121.16.85 8.8.8.8 8.8.4.4
default-router 192.168.10.1
!
!
no ip cef
ip name-server 203.121.16.85
ip name-server 8.8.8.8
ip name-server 8.8.4.4
multilink bundle-name authenticated
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
interface FastEthernet0/0
description *** WAN interface ***
ip address 203.121.26.130 255.255.255.252
duplex auto
speed auto
no cdp enable
!
interface FastEthernet0/1
description *** LAN interface ***
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
no cdp enable
!
interface Serial0/0/0
no ip address
shutdown
no fair-queue
clock rate 2000000
!
router rip
version 2
network 192.168.10.0
network 203.121.26.0
!
ip default-gateway 203.121.26.129
no ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 203.121.26.129
ip route 192.168.10.0 255.255.255.0 FastEthernet0/1
!
no ip http server
no ip http secure-server
!
ip ospf name-lookup
!
!
!
control-plane
!
!
line con 0
password 7 11111111111111111111111
logging synchronous
length 0
line aux 0
line vty 0 4
password 7 11111111111111111111111
logging synchronous
login
!
scheduler allocate 20000 1000
end


回覆
會員
回覆: Cisco IOS routing - 內網無法連上網路
樓主沒有告訴router要做NAT(鵝太久沒摸C牌router了,所以要怎麼config不要問鵝),router是不會"自動"做的....BTW,拿C牌的"純"router當NAT用其實佔不到啥便宜(CPU不夠快,RAM不夠多,IOS也不是每個版本都支援NAT的),沒有特殊須求的話(主要是指接leased line),高檔一點的FW/IP sharing都比拿C牌的"純"router適用就是了....

此篇文章於 2011-12-14 03:28 PM 被 wangcm 編輯。.
回覆
會員
回覆: Cisco IOS routing - 內網無法連上網路
感謝大大的協助
問題已解決.
忘了加入nat/pat.

謝謝


回覆
主題工具


類似的主題
主題 主題作者 討論版 回覆 最後發表
Apple 推出 iOS 4.3.4 版本,解決pdf漏洞 阿 土 -- 其 他 軟 體 討 論 版 0 2011-07-16 02:15 PM
一進到桌面就出現藍底白字 .. vxd ios(01) 范靜善 -- HELP ME 電 腦 軟 硬 體 急 救 版 4 2003-09-13 09:52 PM
【求助】請教何處可下載 Cisco Router IOS 呢?? maguylai -- 網 路 硬 體 版 2 2003-08-06 09:18 AM
【求助】Server Routing Civilizations2 -- 網 路 技 術 版 3 2002-09-18 09:45 AM
【問題】Cisco IOS 12.0 參考庫 cmc600t -- 網 路 技 術 版 0 2002-05-07 09:13 PM






 XML   RSS 2.0   RSS 
本站使用 vBulletin 合法版權程式
站務信箱 : www@pczone.com.tw

本論壇所有文章僅代表留言者個人意見,並不代表本站之立場,討論區以「即時留言」方式運作,故無法完全監察所有即時留言,若您發現文章可能有異議,請 email :www@pczone.com.tw 處理。