【求助】播放H.264的MKV聲音和字幕都延遲的問題


bebo1204
2005-11-07, 11:15 PM
我的配備大概如下
主機板:
CPU 類型 AMD Geode, 1750 MHz (10.5 x 166) 2100+
主機板名稱 MSI KT6 Delta-SR (MS-6590 v2.0) (5 PCI, 1 AGP, 3 DIMM, Audio)
主機板晶片組 VIA VT8377 Apollo KT600
系統記憶體 1024 MB (PC3200 DDR SDRAM)
視訊卡 NVIDIA GeForce4 MX 440 (64 MB)

使用的軟體為
CmplayercXP6484
配合
ATB's CodecS Pack 2.2.0 Lite
ffdshow-20051105-gcc4.0.2

之前用它來看一堆AVI檔,還是一般格式的MKV檔都沒有問題,
可是今天用它來看"喀拉斯",格式都是H.264的MKV檔,
在播放的過程就會有點小問題,
一開始還OK,到後面就會聲音和畫面對不上,
字幕的問題是有時出現有時不出現,就算出現有時又不同步....Orz
不知道是哪邊的問題呢,編碼軟體不夠好,還是我的軟體設定有錯誤,
還是說硬體不夠力呢?

希望有經驗的板友可以指點一下,大感謝~~

ivantw
2005-11-07, 11:57 PM
你不曉得h.264是吃資源怪獸嗎? XD

alumi
2005-11-08, 12:17 AM
您試試去抓KMP 這個播放器回來試試
也許可以幫到你

z18
2005-11-08, 12:41 AM
看看播放時的CPU使用率是否達到100%,是的話改用powerdvd撥看看,
我用賽揚1.3G撥過,使用率降到70-80%。

majimmy
2006-02-04, 09:04 PM
H.264 聽說要 intel p4 3.0CG 以上 才能run!

sliver
2006-02-04, 09:23 PM
試過滿多,最後用的是在PCDVD看到的Google搜尋一下就找到了
Nero Digital MPEG 4 AVC h.264 dshow decoder

lamina
2006-02-05, 12:03 PM
我是用 KMP 搭配 Haali Media Splitter + CoreAVC + CoreAAC
看 1080i ....CPU 使用率大概在 38~49 之間...
配備如左...顯示卡差點 6200TC

lamina
2006-02-05, 03:04 PM
檔案下載

Haali Media Splitter (http://haali.cs.msu.ru/mkv/MatroskaSplitter.exe)
http://haali.cs.msu.ru/mkv/

CoreAVC + CoreAAC (http://lamina.myweb.hinet.net/h264/CodeAVCAAC.zip)

裝完 Haali 的分離器之後,請在 KMP 下面的兩處地方,動手改一下
http://lamina.myweb.hinet.net/h264/h264_1.PNG
http://lamina.myweb.hinet.net/h264/h264_2.PNG

而裝好 CoreAVC + CoreAAC 之後(regsvr32 CoreAAC.ax 和 CoreAVCDecoder.ax)
一樣在 KMP 中改一下,把 CoreAVC 和 CoreAAC 調用出來
http://lamina.myweb.hinet.net/h264/h264_3.PNG
http://lamina.myweb.hinet.net/h264/h264_4.PNG
http://lamina.myweb.hinet.net/h264/h264_5.PNG
http://lamina.myweb.hinet.net/h264/h264_6.PNG

之後播放後,看一下濾鏡
http://lamina.myweb.hinet.net/h264/h264_7.gif




        


本網站是以即時上傳留言的方式運作,一切留言內容只代表發言者個人意見,非本網站之立場,本網站對所有留言的真實性、完整性及立場等,不負任何法律責任。若您發現有某篇留言可能有問題,請 E-Mail 至:www@pczone.com.tw 聯絡我們處理。