pppoe 在Linux 下的問題.....?

顯示結果從第 1 筆 到 3 筆,共計 3 筆
  1. #1
    thx
    thx 目前未上線
    版豬
    註冊日期
    2000-11-19
    所在地區
    100M
    討論區文章
    1,385
    我是看這篇文章安裝的
    http://home.kimo.com.tw/snien/nos/linux/adsl.htm 寫的真的不錯!!

    我用的是Redhat 7.0
    抓的pppoe rpm 是這版本
    http://www.roaringpenguin.com/pppoe/...2.8-1.i386.rpm

    Kenerl...2.2.16-22
    都很順利的安裝上去了

    帳號,dNS ,password 也都ok..
    adsl-status 也都顯示正常
    問題來了
    我打ping... 出去....
    都找不到ip (他都是顯示從我的網卡ip 出去(private ip)
    都是給我從eth0 出去...?(應該是要從pppxx 出去吧)
    請高手指教 初學者一下感激不進 ...



  2. #2
    會員
    註冊日期
    2001-01-21
    討論區文章
    16
    剛開始,我也有這情況,後來才得知是routing的問題,
    可以打netcfg到router設成接ATU-R的那塊網卡,ip不要設
    這樣就可以了...............

  3. #3
    會員
    註冊日期
    2001-02-08
    討論區文章
    66
    先確認你的接法!

    ATU-R------Linux-------HUB------------------User
    |-------------------User
    -------------------User
    這樣接需要兩張網卡!
    Linux-------HUB------------------User
    |-------------------User
    -------------------ATU-R
    這樣接只需乙張網卡!

    Briege 61.xx.xx.xx/192.168.x.1/32 192.168.x/24

    所以你需要確認你的PPP 介面有正常啟動!
    ifconfig
    eth0 ---------192.168.x.1
    eth1 ---------xx.xx.xx.xx
    ppp0 61.xx.xx.xx

    route default gw = ppp0

    從 Client ping Server( Linux eth0 ) OK!

    vi /etc/sysconfig/network

    Forward_IPV4 = yes
    到這都正常,那就是你 Client 沒有設 DNS

    Hinet DNS 168.95.1.1 / 168.95.192.1

    有空再試試吧!
    沒事吧!

類似的主題

  1. 【求助】linux下用sata硬碟的問題
    作者:lelon123 所在討論版:-- FreeBSD & Linux 討 論 版
    回覆: 3
    最後發表: 2005-08-09, 07:31 AM
  2. 【求助】網路卡3c996b-t在linux的問題
    作者:Avery 所在討論版:-- 網 路 硬 體 版
    回覆: 0
    最後發表: 2004-08-09, 03:38 PM
  3. nero 在xp下的問題!
    作者:gds227 所在討論版:-- 光 碟 燒 錄 討 論 版
    回覆: 0
    最後發表: 2003-09-29, 07:05 PM
  4. maxR4在xp下的問題
    作者:angelblack 所在討論版:-- 繪 圖 軟 體 討 論 版
    回覆: 14
    最後發表: 2002-03-18, 01:23 AM
  5. 東森雙向在Linux上的問題
    作者:chewei 所在討論版:-- Cable Modem 心 得 交 流 版
    回覆: 1
    最後發表: 2001-07-25, 04:44 PM

 

此網頁沒有從搜尋引擎而來的訪客

發表文章規則

  • 不可以發表新主題
  • 不可以回覆文章
  • 不可以上傳附加檔案
  • 不可以編輯自己的文章
  •