【求助】raspppoe 與win2000 server 的nat



贊助商連結


cyh
2002-04-19, 12:00 AM
各位先進
我的2000 server 現有2張 nic 1張為內部的virtual ip 另一張沒有設定ip位置
現在我把raspppoe 裝上後…用ics 的服務可以使內部的電腦全部上internet
但是我想要用的是nat 功能…
希望的理想態
clients---hub----
(virtual ip(2000server)無指定ip的nic + raspppoe(0.96版))
--hub---adsl(giga 768/128)------internet
我試了很久…好像不行…在路由及遠端存取中 外部的nic我找不到要選那一個
內部的就是選 virtual ip的那一張…
在路由及遠端存取的畫面中並不會像giga附的軟体在路由及遠端存取中會出現另一張網卡…有解出此問題的先進能告訴我如何處理…謝謝

贊助商連結


cyh
2002-04-19, 09:18 PM
由於 davis 先進的提示…經過3個小時的努力…終於知道了如何使用raraspppoe 與win2000 server 的nat 怎麼使用
謝謝了…

adamlee
2002-04-24, 04:18 PM
最初由 cyh 發表
由於 davis 先進的提示…經過3個小時的努力…終於知道了如何使用raraspppoe 與win2000 server 的nat 怎麼使用
謝謝了…

兩位先進,可以麻煩你們解說一下設定的步驟嗎...我試了好久都不成功....
拜託了 ><

cyh
2002-04-24, 10:32 PM
1.開啟遠端路由
2.internet 連線伺服器
3.選nat
4.建立新的指定撥號連線
5.使用數據机………來連線
6.出現方塊如要全選就全選…(我是只有用xxxxxx ip封包)
7.他會叫你用使用者名稱(打adsl 的username)
網域(我沒打)
password(請打adsl的)
8.就會出現方塊說要不要看nat的說明(我是沒打勾…)
以上就是我設的結果…
如果順利的話…應該可成…還有就是成功後很像固定制的adsl不用撥號喔…
開机後就可讓client端使用…而且再也不用撥接的動作了…
試試看吧…如果順利請再po上來告知…謝謝

mei1533
2002-04-25, 02:49 AM
諸位先進,小弟我本人也被這個問題困擾許久.
我已經做了上述的動作,但是還是行不通!
可否再教教愚笨的我呢?
萬分感謝!!!!

mei1533
2002-04-28, 04:01 PM
諸位,小弟在此再多補充一點我的問題!
我已將win2000 server 升級到AD,有自己的DOMAIN,不再使用WORKGROUP!
如果是這樣的設定,是不是也能讓DOMAIN內的CLIENTS(無論98 OR 2000PRO)也能上網呢?
還是在CLIENTS端要有不一樣的設定呢?
感謝諸位的不吝賜教!!

adamlee
2002-04-29, 11:45 AM
最初由 Davis 發表


寄給你的EMAIL都被退回來了.....:(

Hi Davis兄,不好意思 可以麻煩您重寄至 adamlee@beacontech.com.tw 嗎? 謝謝你嘍^O^
P.S 在新增的撥號連線中(For Dynamic ADSL),其通訊協定是否要有PPPoE? 因為很奇怪的一點是--我可以新增PPPoE至網卡,但卻不能在此撥號連線中新增...我也是使用RASPPPoE 0.96版...我的想法是,若是Win2000 RRAS 的撥號連線內有PPPoE Protocol,"應該"就可以撥號成功.
因為目前我新增撥號連線後,連手動撥號都不成功,根本就不必要設定NAT了...煩請指導一下 >< 麻煩您了~~

mei1533
2002-04-29, 05:09 PM
Davis兄,感謝你的指導,我的CLIENT端已經都能順利上網了!!!
只不過還有一個小問題,那就是當我起動指定撥號連線後,大約要等個一分鐘才可以上網!
這是不是和小烏龜有關呢?
順便一提, AD和NAT在同一台,LOADING還真的是重了一點呢!!!

cyh
2002-04-29, 11:19 PM
請問一下…我覺得有點疑惑了…因為我設定時就按上述的設定可以用啊
為什麼 mei1533 您不能用呢…
因為我又重新設定一次…還是可以啊…還是我沒有在上面po清楚…是否為
1.
2.
...
5.或
6.中間有一個電話號碼或連線位置的問題…我是在裡面打上giga給的位置為(giga_tainan-64.120
剩下的我就沒有改了…
是不是這樣的原因啊…
先進davis是否能解答一下呢?謝謝

adamlee
2002-04-30, 04:51 PM
最初由 Davis 發表


我知道你說的那格. 事實上我在那個欄位裡根本沒有填入任何資料, 照樣可以撥得出去.
還有, mei1533在下午五點時也回報成功了喲! 多謝你整理出步驟, 你可是幫了大忙呢! :)

Davis兄,謝謝您的協助,小弟我已經測試成功了^O^ ^O^ ^O^
原來在Demand Dial Interface中並不需要PPPoE的Protocol,之前無法撥號成功的原因應該是網路卡指定錯誤....再次感謝您的幫忙:)